<!DOCTYPE html><!-- HTML 5 -->
<html lang="en-US">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://rockradionetwork.org/xmlrpc.php" />

<!-- Added by SermonBrowser (version 0.45.11) - http://www.sermonbrowser.com/ --><link rel="alternate" type="application/rss+xml" title="Sermon podcast" href="http://rockradionetwork.org/media-center/?podcast" /><title>Media Center | Bible teaching in English and Spanish from Puerto Rico (Yitro | יתרו | "Jethro " - Nita Luttrell)</title>
          <script>
            (function(d){
              var js, id = 'powr-js', ref = d.getElementsByTagName('script')[0];
              if (d.getElementById(id)) {return;}
              js = d.createElement('script'); js.id = id; js.async = true;
              js.src = '//www.powr.io/powr.js';
              js.setAttribute('powr-token','ReefF8bGXI1478611800');
              js.setAttribute('external-type','wordpress');
              ref.parentNode.insertBefore(js, ref);
            }(document));
          </script>
          <link rel="alternate" type="application/rss+xml" title="Bible teaching in English and Spanish from Puerto Rico &raquo; Feed" href="http://rockradionetwork.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bible teaching in English and Spanish from Puerto Rico &raquo; Comments Feed" href="http://rockradionetwork.org/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"http:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/rockradionetwork.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.3.1"}};
			!function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='inline-upload-style-css'  href='http://rockradionetwork.org/wp-content/plugins/inline-upload/css/inline_upload_style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='usp_style-css'  href='http://rockradionetwork.org/wp-content/plugins/user-submitted-posts/resources/usp.css?ver=20130720' type='text/css' media='all' />
<link rel='stylesheet' id='sb_style-css'  href='http://rockradionetwork.org/sb-style.css?ver=1475079730' type='text/css' media='all' />
<link rel='stylesheet' id='asab_style-css'  href='http://rockradionetwork.org/wp-content/plugins/add-smart-app-banner/smart-app-banner.css?ver=4.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://rockradionetwork.org/wp-includes/css/dashicons.min.css?ver=4.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css'  href='http://rockradionetwork.org/wp-content/plugins/post-views-counter/css/frontend.css?ver=4.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='vtslider-css'  href='http://rockradionetwork.org/wp-content/plugins/vertical-tab-slider/css/vtslider.css?ver=4.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimp-for-wp-checkbox-css'  href='http://rockradionetwork.org/wp-content/plugins/mailchimp-for-wp/assets/css/checkbox.min.css?ver=2.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimp-for-wp-form-css'  href='http://rockradionetwork.org/wp-content/plugins/mailchimp-for-wp/assets/css/form.min.css?ver=2.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='smartline-lite-stylesheet-css'  href='http://rockradionetwork.org/wp-content/themes/smartline-lite/style.css?ver=1.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='smartline-lite-genericons-css'  href='http://rockradionetwork.org/wp-content/themes/smartline-lite/css/genericons/genericons.css?ver=3.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='smartline-lite-default-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CBitter&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-standard-css-css'  href='http://rockradionetwork.org/wp-content/plugins/squelch-tabs-and-accordions-shortcodes/css/jquery-ui/start/jquery-ui-1.9.2.custom.min.css?ver=0.3.4' type='text/css' media='' />
<link rel='stylesheet' id='squelch_taas-css'  href='http://rockradionetwork.org/wp-content/plugins/squelch-tabs-and-accordions-shortcodes/css/squelch-tabs-and-accordions.css?ver=0.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='http://rockradionetwork.org/wp-content/plugins/slideshow-gallery/css/colorbox.css?ver=1.3.19' type='text/css' media='all' />
<link rel='stylesheet' id='slideshow-font-css'  href='http://rockradionetwork.org/wp-content/plugins/slideshow-gallery/views/default/css/font.css' type='text/css' media='all' />
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/inline-upload/include/json2.js?ver=4.3.1'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/inline-upload/include/inline_upload_functions.js?ver=4.3.1'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/add-smart-app-banner/smart-app-banner.js?ver=4.3.1'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/vertical-tab-slider/js/jquery.easing.js?ver=4.3.1'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/vertical-tab-slider/js/jquery.slidorion.js?ver=4.3.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/themes/smartline-lite/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var smartline_menu_title = "Menu";
/* ]]> */
</script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/themes/smartline-lite/js/navigation.js?ver=20160421'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/slideshow-gallery/js/gallery.js?ver=1.0'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/slideshow-gallery/js/colorbox.js?ver=1.3.19'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://rockradionetwork.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://rockradionetwork.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.3.1" />
<link rel='canonical' href='http://rockradionetwork.org/media-center/' />
<link rel='shortlink' href='http://rockradionetwork.org/?p=329' />
<!-- start Smart App banners -->	
<meta name="apple-itunes-app" content="app-id=1125199810">	
<meta name="google-play-app" content="app-id=com.subsplashconsulting.s_9SPP96">	
<link rel="apple-touch-icon" href="http://rockradionetwork.org/wp-content/uploads/2016/07/icon-app.png">	
<link rel="android-touch-icon" href="http://rockradionetwork.org/wp-content/uploads/2016/07/icon-app.png" />	
<!-- end of Smart App banners -->	
<link rel="amphtml" href="http://rockradionetwork.org/media-center/amp/"><script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-44573009-1']);
_gaq.push(['_trackPageview']);
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<meta name="generator" content="qTranslate-X 3.4.4" />
<style type="text/css">
.qtranxs_flag_en {background-image: url(http://rockradionetwork.org/wp-content/plugins/qtranslate-x/flags/gb.png); background-repeat: no-repeat;}
.qtranxs_flag_es {background-image: url(http://rockradionetwork.org/wp-content/plugins/qtranslate-x/flags/es.png); background-repeat: no-repeat;}
</style>
<link hreflang="en" href="http://rockradionetwork.org/en/media-center/?sermon_id=4344" rel="alternate" />
<link hreflang="es" href="http://rockradionetwork.org/es/media-center/?sermon_id=4344" rel="alternate" />
<link hreflang="x-default" href="http://rockradionetwork.org/media-center/?sermon_id=4344" rel="alternate" />
<style id="sexy-author-bio-css" type="text/css" media="screen">
					  #sexy-author-bio { background: #333333; border-style: solid; border-color: #444444; color: #ffffff; border-top-width: 20px; border-right-width: 0px; border-bottom-width: 20px; border-left-width: 0px; }
					  #sab-author { font-weight: 400;font-size: 48px;line-height: 48px;}
					  #sab-gravatar { width: 100px;}#sab-gravatar a { color: #0088cc;}
					  #sab-author a { 
					    margin-right:10px;text-decoration: none;text-transform: uppercase;color: #0088cc;}#sab-byline { color: #777777;font-weight: 700;text-decoration: none;text-transform: uppercase;}
					  #sab-description { font-weight: 400;}
					  [id^=sig-] { height: 48px;width: 48px;margin-top: 2px;margin-right: 2px;margin-bottom: 2px;}
					  
					  @media (min-width: 1200px) {
					  
					  }
					  @media (min-width: 1019px) and (max-width: 1199px) {
					  
					  }
					  @media (min-width: 768px) and (max-width: 1018px) {
					  
					  }
					  @media (max-width: 767px) {
					  [id^=sig-] { margin-left: 0;margin-right: 2px;}
					  
					  }
					  </style><style type="text/css" id="custom-background-css">
body.custom-background { background-image: url('http://rockradionetwork.org/wp-content/themes/smartline-lite/images/background.png'); background-repeat: repeat; background-position: top left; background-attachment: scroll; }
</style>
</head>

<body class="page page-id-329 page-template page-template-page-fullwidth page-template-page-fullwidth-php custom-background">


<div id="wrapper" class="hfeed">
	
	<div id="header-wrap">
	
				
		<nav id="topnav" class="clearfix" role="navigation">
			<ul id="topnav-menu" class="menu"><li id="menu-item-1849" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1849"><a href="http://rockradionetwork.org/send-prayer/">Send prayer</a></li>
<li id="menu-item-260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260"><a target="_blank" href="http://bcsonline.org/">BCS online</a></li>
<li id="menu-item-1507" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1507"><a href="http://rockradionetwork.org/contact-us/">Contact</a></li>
<li id="menu-item-1509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1509"><a href="http://rockradionetwork.org/local-english-churches/">English churches</a></li>
<li id="menu-item-25900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25900"><a href="https://publicfiles.fcc.gov/am-profile/wbmj">WBMJ Public File</a></li>
<li id="menu-item-2124" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2124"><a href="http://rockradionetwork.org/how-to-know-jesus/">How to know Jesus</a></li>
<li id="menu-item-2405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2405"><a href="http://rockradionetwork.org/our-newsletter/">Our newsletter</a></li>
<li id="menu-item-2962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2962"><a href="http://rockradionetwork.org/help-wanted-engineeroperator/">Help wanted</a></li>
<li id="menu-item-25899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25899"><a href="http://rockradionetwork.org/?p=3903">Media Center full list</a></li>
</ul>		</nav>
		
			
		<header id="header" class="clearfix" role="banner">

			<div id="logo" class="clearfix">
			
										
		<p class="site-title"><a href="http://rockradionetwork.org/" rel="home">Bible teaching in English and Spanish from Puerto Rico</a></p>
	
					
							
					<h2 class="site-description">WBMJ AM 1190 San Juan | WCGB AM 1060 Juana Díaz/Ponce | WIVV AM 1370 Vieques, Virgin Islands</h2>
							
			</div>
			
			<div id="header-content" class="clearfix">
							</div>

		</header>
	
	</div>
	
	<div id="navi-wrap">
		
		<nav id="mainnav" class="clearfix" role="navigation">
			<ul id="mainnav-menu" class="menu"><li id="menu-item-3476" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3476"><a href="http://rockradionetwork.org">Home</a></li>
<li id="menu-item-1497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1497"><a href="http://rockradionetwork.org/praywall/">Praywall</a></li>
<li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6"><a href="http://rockradionetwork.org/program-guide-mf/">Program Guide</a>
<ul class="sub-menu">
	<li id="menu-item-2223" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2223"><a href="http://rockradionetwork.org/program-guide-addresses/">Program Contact Info</a></li>
	<li id="menu-item-1501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1501"><a href="http://rockradionetwork.org/program-guide-mf/">Monday &#8211; Friday</a></li>
	<li id="menu-item-1502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1502"><a href="http://rockradionetwork.org/program-guide-saturday/">Saturday</a></li>
	<li id="menu-item-1503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1503"><a href="http://rockradionetwork.org/program-guide-sunday/">Sunday</a></li>
	<li id="menu-item-1568" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1568"><a href="http://rockradionetwork.org/?page_id=606">Guía de WCGB</a></li>
	<li id="menu-item-1569" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1569"><a href="http://rockradionetwork.org/?page_id=609">WIVV on Saturdays</a></li>
</ul>
</li>
<li id="menu-item-7" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7"><a href="#">About us</a>
<ul class="sub-menu">
	<li id="menu-item-2408" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2408"><a href="http://rockradionetwork.org/our-newsletter/">Our newsletter</a></li>
	<li id="menu-item-1835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1835"><a href="http://rockradionetwork.org/inside-wbmj/">Inside WBMJ</a></li>
	<li id="menu-item-1841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1841"><a href="http://rockradionetwork.org/inside-wcgb/">Inside WCGB</a></li>
	<li id="menu-item-1844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1844"><a href="http://rockradionetwork.org/inside-wivv/">Inside WIVV</a></li>
	<li id="menu-item-1506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1506"><a href="http://rockradionetwork.org/founder-tribute-dr-don-luttrell/">Founder Tribute: Dr. Don Luttrell</a></li>
	<li id="menu-item-2128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2128"><a href="http://rockradionetwork.org/present-with-the-lord-ruth-luttrell-1926-2014/">Founder Tribute: Ruth Luttrell</a></li>
	<li id="menu-item-1508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1508"><a href="http://rockradionetwork.org/history-of-cem/">History of CEM</a></li>
	<li id="menu-item-3009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3009"><a href="http://rockradionetwork.org/cem-museum/">CEM Museum</a></li>
	<li id="menu-item-2144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2144"><a href="http://rockradionetwork.org/what-we-believe/">What we believe</a></li>
	<li id="menu-item-2150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2150"><a href="http://rockradionetwork.org/cem-mission-statement/">CEM Mission Statement</a></li>
</ul>
</li>
<li id="menu-item-1767" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1767"><a href="#">Give / Donar</a>
<ul class="sub-menu">
	<li id="menu-item-1768" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1768"><a href="http://weblink.donorperfect.com/RockDonate">Give (English)</a></li>
	<li id="menu-item-1769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1769"><a href="http://bit.ly/1F8mM9B">Donar (español)</a></li>
</ul>
</li>
<li id="menu-item-3477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3477"><a href="http://#">Media Center</a>
<ul class="sub-menu">
	<li id="menu-item-25904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25904"><a href="http://subsplash.com/rockpuertorico">New Media Center</a></li>
	<li id="menu-item-3910" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3910"><a href="http://rockradionetwork.org/?p=20221">Classic Media Center</a></li>
</ul>
</li>
<li id="menu-item-25308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25308"><a href="http://rockradionetwork.org/listen-to-wbmj/">Listen live</a>
<ul class="sub-menu">
	<li id="menu-item-25314" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25314"><a href="http://rockradionetwork.org/listen-to-wbmj/">Listen to WBMJ</a></li>
	<li id="menu-item-25313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25313"><a href="http://rockradionetwork.org/listen-to-wcgb/">Listen to WCGB</a></li>
</ul>
</li>
<li id="menu-item-25905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25905"><a href="http://#">FCC Documents</a>
<ul class="sub-menu">
	<li id="menu-item-25906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25906"><a href="http://rockradionetwork.org/wp-content/uploads/2016/11/EEO-Report-_2016_.pdf">EEO Report</a></li>
	<li id="menu-item-25907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25907"><a href="https://publicfiles.fcc.gov/am-profile/wbmj">WBMJ Public File</a></li>
	<li id="menu-item-25908" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25908"><a href="https://publicfiles.fcc.gov/am-profile/wcgb">WCGB Public File</a></li>
	<li id="menu-item-25909" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25909"><a href="https://publicfiles.fcc.gov/am-profile/wivv">WIVV Public File</a></li>
</ul>
</li>
<li id="menu-item-25911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25911"><a href="http://rockradionetwork.org/contact-us/">Contact</a></li>
</ul>		</nav>
		
	</div>
	
				
			<div id="custom-header">
				
								
					<img src="http://rockradionetwork.org/wp-content/uploads/2015/06/top-bar3.jpg" />
					
								
			</div>
		
			
	<div id="wrap" class="clearfix">
		
		<section id="content" class="primary" role="main">
		
					
		
	<div id="post-329" class="post-329 page type-page status-publish hentry">
				
		<h1 class="page-title">Media Center</h1>
		<div class="entry clearfix">
			<div class="sermon-browser-results">
<a href="http://subsplash.com/rockpuertorico">
<img src="http://rockradionetwork.org/wp-content/uploads/2016/09/moved.png" alt="The Media Center has moved" width="500" height="160" border="0">
<div class="fb-like" data-send="false" data-width="440" data-show-faces="true"></div>
	<h2>Yitro | יתרו | "Jethro " <span class="scripture">()</span> </h2>
	<img alt='Nita Luttrell' class='preacher' src='http://rockradionetwork.org/wp-content/uploads/sermons/images/torah.jpg'><span class="preacher"><a href="?preacher=12">Nita Luttrell</a>, February 17, 2017</span><br />
	From our program "<a href="?series=10">Today"s Torah Reading</a>."<br />
	<div class="sermon-description"><p>Yitro | יתרו | "Jethro "</p>
</div>
	<p class="sermon-tags">Tags: <a href="?stag=luttrell">luttrell</a>, <a href="?stag=nita">nita</a>, <a href="?stag=portion">portion</a>, <a href="?stag=reading">reading</a>, <a href="?stag=torah">torah</a></p>
        <br /><br />
		<div class="sermon_file"><audio class="wp-audio-shortcode" id="audio-329-2" preload="none" style="width: 100%; visibility: hidden;" controls="controls"><source type="audio/mpeg" src="http://rockradionetwork.org/media-center/?show&#038;file_name=Torah_Reading_021717_.mp3&#038;_=2" /><a href="http://rockradionetwork.org/media-center/?show&#038;file_name=Torah_Reading_021717_.mp3">http://rockradionetwork.org/media-center/?show&#038;file_name=Torah_Reading_021717_.mp3</a></audio><p><a href="http://rockradionetwork.org/media-center/?show&file_name=Torah_Reading_021717_.mp3">No player? Click here / ¿No reproductor? Haz clic aquí.</a></p> <a href="http://rockradionetwork.org/media-center/?download&amp;file_name=Torah_Reading_021717_.mp3">Download/Descargar - Click here</a></div><img src="http://rockradionetwork.org/wp-content/uploads/2015/02/Download.jpg">
			<div class='preacher-description'><span class='about'>About Nita Luttrell: </span><span class='description'>Nita Luttrell is passionate about sharing the Jewish roots of our Christian faith.</span></div>	</table>
</div>
<br/>
<br/>
----------------------------------------------------------------------
<div id="disqus_thread"></div>
<script type="text/javascript">
    /* * * CONFIGURATION VARIABLES * * */
    var disqus_shortname = 'therockradionetwork';
    
    /* * * DON'T EDIT BELOW THIS LINE * * */
    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
<noscript>Oops!  You need to enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments left by other Rock listeners.</a></noscript>
    
<p>&nbsp;</p>
		
		</div>
		
	</div>		
		

		
		</section>
		
		
	<section id="sidebar" class="secondary clearfix" role="complementary">

		<aside id="text-10" class="widget widget_text clearfix"><h3 class="widgettitle"><span>What is The Rock? / ¿Qué es La Roca?</span></h3>			<div class="textwidget">The Rock Radio Network is a nondenominational Bible teaching ministry based out of San Juan, Puerto Rico.  Since 1956 under the same management, we combine local and off-Island programs in English and Spanish with Christian music, some news, and local events. Listen live <a href="http://rockradionetwork.org/listen-online/">right here</a>.
<br/>
<br/>
La Cadena Radial la Roca es un ministerio de enseñanza bíblica interdenominacional basada en San Juan, Puerto Rico.  Llevamos desde 1956 bajo la misma administración.  Combinamos programas de fuentes locales y de afuera tanto en inglés como en español con música cristiana, noticias, y más. Puede escuchar <a href="http://rockradionetwork.org/listen-online/">aquí en nuestra página</a>.

<center>
<a href="https://www.facebook.com/RockRadioNetwork"><img src="http://rockradionetwork.org/wp-content/uploads/2015/05/fb-icon.png
"></a>
<a href="https://twitter.com/therockradio"><img src="http://rockradionetwork.org/wp-content/uploads/2015/05/097304-3d-transparent-glass-icon-social-media-logos-twitter-logo-square.png
">
</center></div>
		</aside><aside id="enhancedtextwidget-2" class="widget widget_text enhanced-text-widget clearfix"><h3 class="widgettitle"><span>Now playing on The Rock</span></h3><div class="textwidget widget-text"><div id="live-now">		
   <p align="left"> SRN Satellite News       <BR><BR><font color = "blue">Previous<BR>Groundwork               <BR><BR>

</font>
</td>
	</div>
<br/>

<center>
<a href="http://community.therockradio.org/SF8003000.wav"><img src="http://rockradionetwork.org/wp-content/uploads/2015/10/daily-weather-steve-dendrinos-wbmj.png"></a>
</center></div></aside><aside id="text-8" class="widget widget_text clearfix"><h3 class="widgettitle"><span>All the latest programs ^</span></h3>			<div class="textwidget"><center>
<a href="https://itunes.apple.com/us/podcast/bible-teaching-in-english/id814497015?mt=2"><img src="http://rockradionetwork.org/wp-content/uploads/2016/03/itunes-logo.jpg
"></a>
</center>

To see the full list of latest content in the Media Center, <a href="http://rockradionetwork.org/?p=3903">click here.</a> <br/><br>

Para ver la lista completa de los programas más actualizados en el Centro de Medios, <a href="http://rockradionetwork.org/?p=3903">oprime aquí.</a>

</div>
		</aside><aside id="text-5" class="widget widget_text clearfix"><h3 class="widgettitle"><span>Visit/Like</span></h3>			<div class="textwidget"><center>
<a href="https://www.facebook.com/RockRadioNetwork"><img src="http://rockradionetwork.org/wp-content/uploads/2015/05/fb-icon.png
"></a>
<a href="https://twitter.com/therockradio"><img src="http://rockradionetwork.org/wp-content/uploads/2015/05/097304-3d-transparent-glass-icon-social-media-logos-twitter-logo-square.png
">
</center>

<a href="http://rockradionetwork.org/wp-login.php">Login</a>
</div>
		</aside>
	</section>
		
	</div>
	

		
	<footer id="footer" class="clearfix" role="contentinfo">
		
				
		<div id="footer-text">
			
			
	<span class="credit-link">
		Powered by <a href="http://wordpress.org" title="WordPress">WordPress</a> and <a href="https://themezee.com/themes/smartline/" title="Smartline WordPress Theme">Smartline</a>.	</span>

		
		</div>
		
	</footer>

</div><!-- end #wrapper -->

<script type="text/javascript">
      new SmartBanner({
          daysHidden: 15,   
          daysReminder: 20,
          appStoreLanguage: 'us', 
          title: 'WBMJ',
          author: 'WBMJ',
          button: 'Get our app!',
          store: {
              ios: 'On the App Store',
              android: 'In Google Play',
              windows: 'In Windows store'
          },
          price: {
              ios: '0',
              android: '0',
              windows: 'Free'
          }
          // , force: 'ios' // Uncomment for platform emulation
      });
    </script><link rel='stylesheet' id='remove-style-meta-css'  href='http://rockradionetwork.org/wp-content/plugins/wp-author-date-and-meta-remover/css/entrymetastyle.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://rockradionetwork.org/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.17.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://rockradionetwork.org/wp-includes/js/mediaelement/wp-mediaelement.css?ver=4.3.1' type='text/css' media='all' />
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/squelch-tabs-and-accordions-shortcodes/js/squelch-tabs-and-accordions.js?ver=0.3.4'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Download File":"Download File","Download Video":"Download Video","Play\/Pause":"Play\/Pause","Mute Toggle":"Mute Toggle","None":"None","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Unmute":"Unmute","Mute":"Mute","Captions\/Subtitles":"Captions\/Subtitles"}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.17.0'></script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-includes/js/mediaelement/wp-mediaelement.js?ver=4.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"therockradionetwork"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rockradionetwork.org/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.3.1'></script>
</body>
</html>